Loading...

Knowledge Base

Account Email Verification Link Not Working

This page explains what to do if your Crazy Domains email verification link is not working or leads to a 404 Not Found Error page. By the end, you’ll understand why this happens and how to resend a new verification link to complete the process.

 

Problem

When clicking the email verification link, it does not work or redirects you to a "404 Not Found" page. This issue includes situations where the registrant contact email verification link also redirects to a 404 page.

This affects:

  • Registrant email verification
  • Email on file verification
  • Assign contact verification

 

 

Cause

This issue usually occurs when:

  • The verification link has expired, or
  • The verification process has already been completed

 

Solution

For Email on File Verification

If you’re verifying your account email address, follow these steps:

  1. Log in to your Crazy Domains Account.
  2. Navigate to the Account Security Settings.
  3. Select the option to Resend the Verification Link.
  4. Check your email for the new verification link and follow the instructions to complete the process.

 

For Registrant Email Verification

If you’re verifying a registrant contact email, follow these steps:

  1. Log in to your Crazy Domains Account.
  2. Navigate to the Contact or Administration section of the domain.  
  3. Click the Resend the verification link option.  
  4. Follow the instructions in the email to complete the verification.

 

 

Loading...